Support lifecycle, system requirements, and supported browsers for Front

Overview

You can connect to Front in a number of ways! In an ongoing effort to provide a more safe and secure platform, as well as facilitate growth and roll out innovations, Front receives regular updates.

Below is the support lifecycle policy and a list of the supported operating system(s) (OS), app(s), and browser version(s) that have recently reached, or will soon reach, the end of support.

If you're using any of the versions that are in a lower version than what is listed here, please update to continue using Front.


Support lifecycle policy

The support that we provide to desktop app versions, browsers, and mobile app versions can span different periods of time. This can be impacted by development cycles and customers' needs.

Attempting to use Front on an unsupported version may prevent you from using Front. Check for app updates to regain access.

OS or browser

Length of support

Browsers

12-18 months from release

Mac

12-18 months from release

Windows

12-18 months from release

iOS

2.5-3 years from release

Android

2.5-3 years from release

 


Desktop app

Here is a list of the currently supported operating systems (OS) for Front’s desktop app. For the best experience, we recommend using the latest versions.

OS version

App version

Mac 10.11 (El Capitan and higher) 

3.26.0 or higher

Windows 7 and higher

3.26.0 or higher

 


Mobile app

Here is a list of the currently supported operating systems (OS), and app versions, for Front’s mobile app. For the best experience, we recommend using the latest versions.

Operating system

OS version

App version

iOS

12.0 or higher

5.8.4

Android*

5.0 or higher

5.8.4

*We only support Android devices that have Google Play Services installed by default.


Browser

Supported browsers

Front supports the following browsers for the web app:

  • Recommended: Google Chrome

  • Microsoft Edge

  • Firefox

  • Safari

  • Opera

You can log into Front on the web at app.frontapp.com, or via your SSO (Single Sign-On portal, such as Okta or OneLogin). 

Front is not supported via Internet Explorer.

Browser extensions

Front supports common extensions like Grammarly or Auto Text Expander on web browser.

Ad blockers

Some ad-blockers, such as uBlock, are known to block some critical components Front requires to operate. If you are experiencing unexpected behavior when using Front in a browser with an ad-blocker enabled, we suggest disabling the ad-blocker for app.frontapp.com.

If using the Brave web browser, you will need to disable Shields for app.frontapp.com in order to use Front with Brave.

Browser End of Life

When a web browser itself or browser version is no longer supported, you may see a degraded experience in the browser. This can include but is not limited to signing in, navigating to different areas within Front, composing drafts, creating rules, and managing your settings. It would be best to perform regular updates to your browser for the most stable experience.

2replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
    • arvind
    • arvind
    • 2 yrs ago
    • Reported - view

    Hi, how can I use the browser extension especially the Grammarly?

    Like
  • If the Grammarly extension isn't installed on your Chrome now. Go to their web-site and install the extension. Then, log out of the Front web site (you may need to close your Chrome browsers), then re-launch the app.frontapp.com. Front will see the Grammarly extension.

    Like
Like Follow
  • 1 mth agoLast active
  • 2Replies
  • 2596Views
  • 3 Following