Receiving messages with delay warnings
Overview
If you see the error message "This message was delivered to Front {n} minutes after it was sent." in Front, see below for common causes.
Common causes
When an email is sent, it is passed sequentially through a number of mail servers or mail services until it reaches the recipient's mailbox. These handoffs between mail servers and services are referred to as hops.
Typically the process of sending an email and having it arrive in the recipient's mailbox takes just a couple of seconds. However, there are some cases where certain hops can take longer than usual.
Example 1: When the received email is passing through a final spam checking service or firewall belonging to the recipient. If this service is unsure the message is safe, it might want to perform additional checks on the message, and take longer to verify the message is safe before passing it to the recipient's mailbox.
Example 2: One or more of the mail processing services which handle the message may be overloaded at the time the message was sent, leading to temporary processing delays.
How it works
In cases where Front detects a notable delay (5 minutes or longer) between the time a message was sent, and the time Front received it, the warning shown above will be displayed on the message to indicate that there was a message delivery delay outside of Front's control.
The warning will disappear after a relative amount of time depending on how long the message import delay was. e.g. The longer the delay, the longer the warning will be present on the specific message.
Note: These warnings are currently displayed for SMTP forwarding channels only, not for email channels connected via Gmail or Office 365 sync.